svn

Upgrade to Apache 2.2 on Gentoo (PHP5 SVN SSL)

How to easily upgrade Apache 2.2 running PHP5 and SVN with SSL under Gentoo.

Recently I've upgraded the Apache on my gentoo server from 2.0 to 2.2.

Because it looked like just the minor change in numbers I ahven't even read the documentation. Silly me.

Everything stopped. SSL, SVN and even PHP. Mainly because configuration files are changed and it's upgrade is destroying some of the old settings. Someone said that it should be name Apache 3.0, from the configuration point of view – I have to agree.

Here are the steps one should take to make the whole process successful.